summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:52 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:52 -0500
commit59ef1c711cc8382ee603d10b90709f6357c9df92 (patch)
treea3573d9d95acf36d4268ac3320ec49c6e6aaab9f /Makefile.am
parentb90e48819b0a52139f290116fac44a533e566b25 (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 22eedd9..acba027 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -51,3 +51,13 @@ install-data-hook:
distuninstallcheck:
@:
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog