summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin E Martin <kem@kem.org>2005-11-15 08:29:17 +0000
committerKevin E Martin <kem@kem.org>2005-11-15 08:29:17 +0000
commitf72272f3950f3c5e503a2971e7ffdbe4d34c8639 (patch)
tree39ac4e10f295f5613a3c517b1682103bf63475ce /configure.ac
parent633f26575d06995a8a4fd66ebaeb59563e15ea3c (diff)
Add configure option to change the installed font dir.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f9d3c6c..b020679 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,6 +30,13 @@ AC_PROG_INSTALL
AC_PATH_PROG(MKFONTDIR, mkfontdir)
+DEFAULT_FONTDIR=${libdir}/X11/fonts/Speedo
+AC_ARG_WITH(fontdir,
+ AS_HELP_STRING([--with-fontdir=FONTDIR], [Path to install fonts]),
+ [FONTDIR="$withval"],
+ [FONTDIR="$DEFAULT_FONTDIR"])
+AC_SUBST(FONTDIR)
+
XORG_RELEASE_VERSION
AC_OUTPUT([Makefile])