summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:41 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:41 -0500
commit553dbc701d5f1669a2797d530286743a81104cbf (patch)
tree51e41320361674d11e2656d08d492b6d742e6ed7 /Makefile.am
parent657e312e55a4138425773db5cc6c6ac56615436b (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5ef15b3..38b47d8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -179,3 +179,13 @@ install-data-hook:
distuninstallcheck:
@:
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog