summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:38 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:38 -0500
commit0bb68e3cbfbc59a227f1322a51e4dd54ec9a500e (patch)
tree7284125bf355dc1776f069556be50114ab053568 /Makefile.am
parent2f091765f8e5e347af1f0d63ca223460e75af7ac (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a692d9f..bf2751a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -262,3 +262,13 @@ install-data-hook:
distuninstallcheck:
@:
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog