summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2008-11-29 06:39:12 -0200
committerPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2008-11-29 06:39:12 -0200
commita0d4a4755c528c924f23000f83c5712f65593087 (patch)
tree5656259e7d82275fbc5aecf59cd56e7ac9c71aac /configure.ac
parent97e2d12548921d92b6dc2dcce8abee48f25981d2 (diff)
Make ISA support optional.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index be83b67..a22236f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,6 +66,14 @@ AC_CHECK_HEADER(xf1bpp.h,[AC_DEFINE(HAVE_XF1BPP, 1, [Have 1bpp support])],[])
AC_CHECK_HEADER(xf4bpp.h,[AC_DEFINE(HAVE_XF4BPP, 1, [Have 4bpp support])],[])
CPPFLAGS="$SAVE_CPPFLAGS"
+SAVE_CFLAGS="$CFLAGS"
+CFLAGS="$XORG_CFLAGS"
+AC_CHECK_DECL(xf86ConfigIsaEntity,
+ [AC_DEFINE(HAVE_ISA, 1, [Have ISA support])],
+ [],
+ [#include "xf86.h"])
+CFLAGS="$SAVE_CFLAGS"
+
if test "x$XSERVER_LIBPCIACCESS" = xyes; then
PKG_CHECK_MODULES([PCIACCESS], [pciaccess >= 0.8.0])
XORG_CFLAGS="$XORG_CFLAGS $PCIACCESS_CFLAGS"