summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-10-03 21:22:08 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-10-03 21:22:08 +0000
commitd172ee452c165b625821e2035a28a2bdb32344f0 (patch)
tree9ea0e9106daaed2c674c8f030de76999f35c66bb /Makefile.am
parent18f6c6e9f560315b51f6b0cce601a5c4b70d471e (diff)
- For all drivers that have a <driver>.sgml file, add code in their build
system to build the README file at make dist time - in util/macros/xorg-macros.m4, add a new XORG_CHECK_LINUXDOC macro that will check if the required tools and files exist, and if so set a conditional. - util/modular/symlink.sh - Link all the <driver>.sgml to xf86-video-<driver>/README.sgml - Add all the README.<driver> to the list of excluded files - xc/programs/Xserver/hw/xfree86/doc/sgml/SiS.sgml: Various changes to make it spew less warnings when the text file is built.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 16f4412..0dce475 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,3 +20,10 @@
AUTOMAKE_OPTIONS = foreign
SUBDIRS = src
+
+if BUILD_LINUXDOC
+README: README.sgml
+ $(MAKE_TEXT) README.sgml && mv README.txt README
+endif
+
+EXTRA_DIST = README.sgml