summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2009-10-26 12:54:22 -0400
committerGaetan Nadon <memsize@videotron.ca>2009-10-26 12:54:22 -0400
commit06b06031792a205f18a7a8546512a613072269d7 (patch)
tree4483308dd186844a4b2fa2d0fea98e8bc28561ee /Makefile.am
parent5fd40c5ad920f75f0984ac125106dd2acd195544 (diff)
Several driver modules do not have a ChangeLog target in Makefile.am #23814
The git generated ChangeLog replaces the hand written one. Update configure.ac to xorg-macros level 1.3. Use XORG_DEFAULT_OPTIONS which replaces four XORG_* macros Update Makefile.am to add ChangeLog target if missing Remove ChangeLog from EXTRA_DIST or *CLEAN variables This is a pre-req for the INSTALL_CMD
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0dce475..4153d4c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,3 +27,10 @@ README: README.sgml
endif
EXTRA_DIST = README.sgml
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ $(CHANGELOG_CMD)
+
+dist-hook: ChangeLog