summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2009-10-26 12:54:22 -0400
committerGaetan Nadon <memsize@videotron.ca>2009-10-26 12:54:22 -0400
commita98a597961df39462d6ce5312c15fa09e9cd20f7 (patch)
treee39b499848030aa288783b26e17b9ea9fda18aca /Makefile.am
parentaa759fdc52c4f6a8a7d1b5cd66bb6cab31c9a77e (diff)
Several driver modules do not have a ChangeLog target in Makefile.am #23814
The git generated ChangeLog replaces the hand written one. Update configure.ac to xorg-macros level 1.3. Use XORG_DEFAULT_OPTIONS which replaces four XORG_* macros Update Makefile.am to add ChangeLog target if missing Remove ChangeLog from EXTRA_DIST or *CLEAN variables This is a pre-req for the INSTALL_CMD
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7052905..8b7c3c7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,3 +20,10 @@
AUTOMAKE_OPTIONS = foreign
SUBDIRS = src man
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ $(CHANGELOG_CMD)
+
+dist-hook: ChangeLog