summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Hopf <mhopf@suse.de>2009-09-02 16:45:12 +0200
committerMatthias Hopf <mhopf@suse.de>2009-09-02 16:45:12 +0200
commit27cfbaa3c34844771b5a4262a5deaf71b79cb6bc (patch)
treed529e98c1ba62da4eb5467959abccd0f3e461583 /configure.ac
parentfa6312784e3a03afb17ec1ea5e0e1912ca34d2b9 (diff)
atombios.h prohibits -std=c99 due to unnamed unions
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 58cf072..c12da87 100644
--- a/configure.ac
+++ b/configure.ac
@@ -314,15 +314,15 @@ do
AC_PROG_CC_FLAG($w,[WARN_CFLAGS="$WARN_CFLAGS $w"],)
done
-# Due to AtomBIOS spitting out too much with -pedantic
+# atombios.h prohibits -std=c99 due to unnamed unions
PEDANTIC_CFLAGS=""
-for w in -pedantic -Wno-long-long -Wno-variadic-macros ; do
+for w in -Wno-long-long -Wno-variadic-macros ; do
AC_PROG_CC_FLAG($w,[PEDANTIC_CFLAGS="$PEDANTIC_CFLAGS $w"],)
done
# AtomBios special flags
ATOMBIOS_CFLAGS=""
-for w in -std=c99 -Wno-unknown-pragmas ; do
+for w in -Wno-unknown-pragmas ; do
AC_PROG_CC_FLAG($w,[ATOMBIOS_CFLAGS="$ATOMBIOS_CFLAGS $w"],)
done