summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <hun@n-dimensional.de>2008-07-17 22:40:32 +0200
committerHans Ulrich Niedermann <hun@n-dimensional.de>2008-07-17 23:18:40 +0200
commit2bc4450aae4aa6d6644c3c0e7fd9612d9301fb22 (patch)
tree2db2235954b54487e8872e2f13cd4b2a7867fa93 /Makefile.am
parent4134177ee30969f9e426cd590e2e8b6743a1541c (diff)
Use 'git foo' instead of 'git-foo'
git upstream have declared the 'git-foo' syntax to be deprecated, and it has already been removed from standard git installs, even if many OS vendors are still shipping git packages with git-foo in the default PATH. The updated scripts using 'git foo' should still be compatible with git >= 1.3.0 with respect to the 'git foo' vs 'git-foo' issue, and with git >= 1.4.0 wrt the git commands themselves.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 54df8dd..e34a5a6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,8 +30,9 @@ MAINTAINERCLEANFILES = ChangeLog
.PHONY: ChangeLog
+# "git log" with the space should be available since git 1.3.0
ChangeLog:
- (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+ (GIT_DIR=$(top_srcdir)/.git git log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
dist-hook: ChangeLog