summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlon Levy <alevy@redhat.com>2011-12-18 19:48:57 +0200
committerAlon Levy <alevy@redhat.com>2011-12-19 11:37:37 +0200
commit5da2a6e4999265b717a7fd18039a90edcd9ba941 (patch)
tree2fbca9fa7e3b97cbd4699237592f82f8eb212842 /configure.ac
parent10d122e7bc9a78be17b130c27495564562bf0f93 (diff)
configure.ac: support autoconf 2.63
AC_CHECK_FILE(cond,[not-empty],[]) in autoconf 2.63 produces an empty else that is illegal for bash, but forgoes the else when given a AC_CHECK_FILE(cond,[not-empty]). 2.68 produces correct output on both, so it's unaffected.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 581521e..22b2e3d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -110,7 +110,7 @@ PKG_CHECK_MODULES([SPICE_PROTOCOL], [spice-protocol >= 0.8.1])
AC_CHECK_FILE(.git, [
GIT_VERSION=`git log -1 --format=%h`
AC_DEFINE_UNQUOTED([GIT_VERSION], ["$GIT_VERSION"], [Defined if building from git])
- ], []
+ ]
)
AC_CONFIG_FILES([