summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stone <daniel@fooishbar.org>2006-12-06 18:46:00 +0200
committerDaniel Stone <daniels@endtroducing.fooishbar.org>2006-12-06 18:46:00 +0200
commit55d283a8c2347e809dadace3fb9a026bab6d57dd (patch)
tree6fbb0b817714c2039a2dd7a44b495445420843ba /Makefile.am
parentfbbbb853041ae4af36eeffb24188b9a5513ba7d5 (diff)
Makefile.am: fix ChangeLog hook
Make ChangeLog hook safe for all situations I could think of, including carrying the ChangeLog through for distcheck when objdir != srcdir. It's significantly more ugly, but eh.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d05c5ca..59e0db2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,6 +27,6 @@ EXTRA_DIST = README_HALLIB mga_PInS.txt ChangeLog
.PHONY: ChangeLog
ChangeLog:
- git-log > ChangeLog
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
dist-hook: ChangeLog