summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-10-03 21:22:07 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-10-03 21:22:07 +0000
commit431d0e144ae4c294e1f6110fc3db497ce9bd9cfd (patch)
treec35b7320f9a8e053c19d7b8a8549de4857bea8ff /Makefile.am
parent9147c20e5ff662ac511a19e7623b406dffee2242 (diff)
- For all drivers that have a <driver>.sgml file, add code in their build
system to build the README file at make dist time - in util/macros/xorg-macros.m4, add a new XORG_CHECK_LINUXDOC macro that will check if the required tools and files exist, and if so set a conditional. - util/modular/symlink.sh - Link all the <driver>.sgml to xf86-video-<driver>/README.sgml - Add all the README.<driver> to the list of excluded files - xc/programs/Xserver/hw/xfree86/doc/sgml/SiS.sgml: Various changes to make it spew less warnings when the text file is built.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7052905..16e0502 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,3 +20,14 @@
AUTOMAKE_OPTIONS = foreign
SUBDIRS = src man
+
+if BUILD_LINUXDOC
+README.ati: README.ati.sgml
+ $(MAKE_TEXT) README.ati.sgml && mv README.ati.txt README.ati
+
+README.r128: README.r128.sgml
+ $(MAKE_TEXT) README.r128.sgml && mv README.r128.txt README.r128
+
+endif
+
+EXTRA_DIST = README.ati README.r128 README.ati.sgml README.r128.sgml