summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2015-03-17 09:45:09 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2015-03-17 09:48:43 +0000
commitbacaf7f18c2f4d3b5cb6bd6145dfb79fa4096759 (patch)
tree183774293a905129e6ea09ced0c4d4fd1d530b21 /configure.ac
parent9d0d78230aaf8863a96d75e8b57bb62e51121b8a (diff)
sna: Use struct pixman_f_vector for compatibility with older pixman
Or else face compile failures: blt.c: In function 'affine_blt': blt.c:1403:3: error: unknown type name 'pixman_f_vector_t' blt.c:1407:4: error: request for member 'v' in something not a structure or union blt.c:1408:4: error: request for member 'v' in something not a structure or union blt.c:1409:4: error: request for member 'v' in something not a structure or union blt.c:1411:3: warning: passing argument 2 of 'pixman_f_transform_point_3d' from incompatible pointer type [enabled by default] In file included from /usr/include/xorg/miscstruct.h:52:0, from /usr/include/xorg/regionstr.h:52, from /usr/include/xorg/region.h:50, from /usr/include/xorg/window.h:51, from /usr/include/xorg/input.h:55, from /usr/include/xorg/xf86str.h:38, from sna.h:43, from blt.c:32: /usr/include/pixman-1/pixman.h:247:15: note: expected 'struct pixman_f_vector *' but argument is of type 'int *' blt.c:1413:7: error: request for member 'v' in something not a structure or union blt.c:1415:7: error: request for member 'v' in something not a structure or union Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 28a47493..9aadc73e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -447,6 +447,7 @@ fi
PKG_CHECK_MODULES(XORG, [xorg-server >= $required_xorg_server_version xproto fontsproto pixman-1 >= $required_pixman_version $REQUIRED_MODULES])
ABI_VERSION=`$PKG_CONFIG --variable=abi_videodrv xorg-server`
XSERVER_VERSION=`$PKG_CONFIG --modversion xorg-server`
+PIXMAN_VERSION=`$PKG_CONFIG --modversion pixman-1`
if test "x$ONLY_UMS" = "xyes"; then
UMS="yes"
@@ -914,6 +915,7 @@ fi
echo ""
echo "AC_PACKAGE_STRING will be compiled with:"
echo " Xorg Video ABI version: $ABI_VERSION (xorg-server-$XSERVER_VERSION)"
+echo " pixman version: pixman-1-$PIXMAN_VERSION"
echo " Acceleration backends:$accel_msg"
echo " Additional debugging support?$debug_msg"
echo " Support for Kernel Mode Setting? $KMS"