summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2015-03-04 11:19:09 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2015-03-04 11:20:50 +0000
commit8d76f90e2cd560c315595e679679cefbcf422fb4 (patch)
treef60d7cf975b6af2a10baa5ff9369830bcb02772f /configure.ac
parent3e390ec4110519746f2edbb3c38a40f0fc415430 (diff)
tools: Add simple tool to retrieve the current cursor from X
Slightly more funky would be to poke around in the CRTC, but that should require master. As it stands this should help verify that what X is supplying to the driver matches user expectations Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a7cdd93f..c5356e2f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -312,6 +312,9 @@ if test "x$tools" != "xno"; then
tools="no"
fi
+ PKG_CHECK_MODULES(TOOL_CURSOR, [xfixes x11 libpng], [cursor="yes"], [ivo="no"])
+ AM_CONDITIONAL(BUILD_TOOL_CURSOR, test "x$cursor" != "xno")
+
IVO_CFLAGS="$IVO_CFLAGS $extra_cflags"
fi
if test "x$tools" != "xno"; then