summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2015-01-28 11:44:41 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2015-01-28 11:46:43 +0000
commit2e7ae76038c808d80c39dfaa56ad4648cd94e7fc (patch)
treed40163d890c9fcfdfa2b3fbca39c6693e718d15d /configure.ac
parent6f6190abcfc3abdefdb2826415e242749fcfb9f8 (diff)
test/dri2: Use xcb for more accurate timing of SwapBuffers
To do SwapBuffers correctly requires a Swap/Get buffers combination, and this is easiest using xcb rather than xlib. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 37047220..07e6af1a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -205,7 +205,7 @@ if test "x$UDEV" != "xno"; then
fi
fi
-PKG_CHECK_MODULES(X11, [x11 xrender xrandr xext xfixes cairo cairo-xlib-xrender pixman-1 libpng], [x11="yes"], [x11="no"])
+PKG_CHECK_MODULES(X11, [x11 x11-xcb xcb-dri2 xrender xrandr xext xfixes cairo cairo-xlib-xrender pixman-1 libpng], [x11="yes"], [x11="no"])
AM_CONDITIONAL(HAVE_X11, test "x$x11" = "xyes")
cpuid="yes"