summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillem Jover <guillem@hadrons.org>2010-10-21 05:22:41 +0200
committerGuillem Jover <guillem@hadrons.org>2010-10-21 07:31:35 +0200
commitbe66973a0851b20a38911db3ef5413d60127b2af (patch)
tree49349dc069e650ed386a35ee4b0500576676ddc2 /configure.ac
parentef45124f827e9b851c99bb8dbe29987e765cb85e (diff)
Fix support for latest glide3x
This enables the driver to use libglide3x.so at run-time instead of libglide2x.so, selectively depending on the headers specified at configure time via --with-glide-include-dir. glide3x is the newer interface and supports more hardware than glide2x.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 85ad072..2f8adcc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,6 +76,9 @@ AC_HEADER_STDC
AC_CHECK_HEADER([glide.h], [],
[AC_MSG_ERROR([<glide.h> is required])])
+AC_CHECK_DECL([grGet], [AC_DEFINE(GLIDE3, 1, [glide3x available])], [],
+ [#include <glide.h>])
+
GLIDE_CFLAGS="-I$glideincludedir"
AC_SUBST([GLIDE_CFLAGS])
AC_SUBST([XORG_CFLAGS])