summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJulien Cristau <jcristau@debian.org>2007-09-07 03:06:25 +0200
committerJulien Cristau <jcristau@debian.org>2007-09-07 03:06:25 +0200
commit939750c472f9c209a4bdb233df36ce649660ffa8 (patch)
treefd629a794611879f95583449a9a1d95a56a0e999 /Makefile.am
parent5bf3ca5537470888614d21e0d8920d3030d4116c (diff)
remove ChangeLog, add dist hook
Remove ChangeLog from the tree, and add a git dist hook to generate it automatically.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7052905..3abadec 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,3 +20,14 @@
AUTOMAKE_OPTIONS = foreign
SUBDIRS = src man
+
+EXTRA_DIST=ChangeLog autogen.sh
+
+CLEANFILES=ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog