summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:36 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:36 -0500
commit776ed20c42f93dc70c055b9f53112b3c827bf702 (patch)
tree37673425c3c3ffe755e4a432cb66b9db4ea4f5a8 /Makefile.am
parent40a33d1fdfccecb1b5d5c88e75b0efa8c2bb0c57 (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7bf230b..4168e4d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -238,3 +238,13 @@ EXTRA_DIST = \
util/fixindex.awk \
util/indexmacros.t \
util/macros.t
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog