summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJeremy Huddleston <jeremyhu@apple.com>2010-07-10 10:19:14 -0700
committerJeremy Huddleston <jeremyhu@apple.com>2010-07-10 10:19:14 -0700
commit8263f19cf9002c7b5f2967a2bde7af4ed117c1e5 (patch)
treebc51ad1db093e0ba37d26bd25f25186e5f75215a /configure.ac
parent3fa31068bcae6a5bee7fbd41788e13d6d56da8c0 (diff)
strnlen: Fix building on systems without strnlen(3)
Signed-off-by: Jeremy Huddleston <jeremyhu@apple.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4344cf1..45867ae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,6 +42,11 @@ XORG_DEFAULT_OPTIONS
AC_CHECK_FUNCS([strlcat])
+AC_FUNC_STRNLEN
+if test "x$ac_cv_func_strnlen_working" = xyes; then
+ AC_DEFINE(HAVE_STRNLEN, 1, [Define to 1 if you have a working strnlen function.])
+fi
+
# Check for iconv in libc, then libiconv
AC_SEARCH_LIBS([iconv], [iconv], [AC_DEFINE([HAVE_ICONV], 1,
[Define to 1 if you have the iconv() function])])