summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2008-06-20 20:26:32 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2008-06-20 20:26:32 -0700
commitc1fbd8fb41328ded8eab0b7af9dbb3cf934ee966 (patch)
treee36fcd37e8a7347918d4bc17695eb2cea63dabfc /configure.ac
parentbb29523ff1a17608d58d61ad106166c264263c1e (diff)
Fix browser plugin build
Add source files to Makefile that were missed in modularization Use headers specified by mozilla-plugin.pc or firefox-plugin.pc if they exist, instead of the ancient Netscape ones we carry around
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9a0f01d..dcebf9c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,6 +49,23 @@ PKG_CHECK_MODULES(XRX, x11 xt xext xtrans xproxymngproto xau)
AC_SUBST(XRX_CFLAGS)
AC_SUBST(XRX_LIBS)
+# Check for mozilla/firefox plugin headers via pkg-config.
+# If not found, fall back to the ancient copy we carry around.
+if test "x$PLUGIN_CFLAGS" = x ; then
+ PKG_CHECK_MODULES([MOZILLA_PLUGIN], [mozilla-plugin],
+ [PLUGIN_CFLAGS=${MOZILLA_PLUGIN_CFLAGS}], [AC_MSG_RESULT([no])])
+
+ if test "x$PLUGIN_CFLAGS" = x ; then
+ PKG_CHECK_MODULES([FIREFOX_PLUGIN], [firefox-plugin],
+ [PLUGIN_CFLAGS=${FIREFOX_PLUGIN_CFLAGS}], [AC_MSG_RESULT([no])])
+
+ if test "x$PLUGIN_CFLAGS" = x ; then
+ PLUGIN_CFLAGS=-I$(top_srcdir)/plugin/include
+ fi
+ fi
+fi
+AC_SUBST(PLUGIN_CFLAGS)
+
XAW_CHECK_XPRINT_SUPPORT(XRX_PLUGIN)
AC_SUBST(XRX_PLUGIN_CFLAGS)
AC_SUBST(XRX_PLUGIN_LIBS)