summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:29 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:29 -0500
commitde44240d10fe7a34062d0ec81260125073ba6c53 (patch)
treecc7b0276970e73d20326363befc7604d40f7a185 /Makefile.am
parent87cf851a0dc07f2de272f376c2dc105d451cd4a4 (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 57a65f3..461faad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,3 +20,13 @@
# PERFORMANCE OF THIS SOFTWARE.
SUBDIRS = helper plugin libxplugin htdocs cgi-bin testplugin xnest-plugin rx
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog