summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-08-10 11:34:23 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-08-10 11:34:23 -0700
commitc843fa3f4e65f2e1e133633b445f8693b1cc617c (patch)
tree9bcb5af7108ce34aafa1186ec4f9d13f2b4d6311 /Makefile.am
parent20955b2e662bb659533287d86fcd4d1cf75d3551 (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 03e70c6..f0d5195 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,8 +37,16 @@ appmandir = $(APP_MAN_DIR)
appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
-EXTRA_DIST = $(appman_PRE)
+EXTRA_DIST = $(appman_PRE) ChangeLog autogen.sh
CLEANFILES = $(appman_DATA)
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
SED = sed