summaryrefslogtreecommitdiff
path: root/xpxthelloworld/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xpxthelloworld/Makefile.am')
-rw-r--r--xpxthelloworld/Makefile.am36
1 files changed, 34 insertions, 2 deletions
diff --git a/xpxthelloworld/Makefile.am b/xpxthelloworld/Makefile.am
index 9f0a4a7..96cb65f 100644
--- a/xpxthelloworld/Makefile.am
+++ b/xpxthelloworld/Makefile.am
@@ -27,7 +27,39 @@ xpxthelloworld_LDADD = $(XPXTHELLOWORLD_LIBS)
xpxthelloworld_SOURCES = \
xpxthelloworld.c
-dist_man1_MANS = \
+appman_PRE = \
xpxthelloworld.man
-EXTRA_DIST = xpxthelloworld.sgml
+EXTRA_DIST = \
+ xpxthelloworld.sgml
+
+appmandir = $(APP_MAN_DIR)
+
+appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
+
+EXTRA_DIST += $(appman_PRE)
+CLEANFILES = $(appman_DATA)
+
+SED = sed
+
+# Strings to replace in man pages
+XORGRELSTRING = @PACKAGE_STRING@
+ XORGMANNAME = X Version 11
+
+MAN_SUBSTS = \
+ -e 's|__vendorversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
+ -e 's|__xorgversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
+ -e 's|__xservername__|Xorg|g' \
+ -e 's|__xconfigfile__|xorg.conf|g' \
+ -e 's|__projectroot__|$(prefix)|g' \
+ -e 's|__apploaddir__|$(appdefaultdir)|' \
+ -e 's|__appmansuffix__|$(APP_MAN_SUFFIX)|g' \
+ -e 's|__libmansuffix__|$(LIB_MAN_SUFFIX)|g' \
+ -e 's|__adminmansuffix__|$(ADMIN_MAN_SUFFIX)|g' \
+ -e 's|__miscmansuffix__|$(MISC_MAN_SUFFIX)|g' \
+ -e 's|__filemansuffix__|$(FILE_MAN_SUFFIX)|g'
+
+SUFFIXES = .$(APP_MAN_SUFFIX) .man
+
+.man.$(APP_MAN_SUFFIX):
+ sed $(MAN_SUBSTS) < $< > $@