summaryrefslogtreecommitdiff
path: root/xpsimplehelloworld/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xpsimplehelloworld/Makefile.am')
-rw-r--r--xpsimplehelloworld/Makefile.am36
1 files changed, 34 insertions, 2 deletions
diff --git a/xpsimplehelloworld/Makefile.am b/xpsimplehelloworld/Makefile.am
index b62f14f..5ab7d74 100644
--- a/xpsimplehelloworld/Makefile.am
+++ b/xpsimplehelloworld/Makefile.am
@@ -27,7 +27,39 @@ xpsimplehelloworld_LDADD = $(XPSIMPLEHELLOWORLD_LIBS)
xpsimplehelloworld_SOURCES = \
xpsimplehelloworld.c
-dist_man1_MANS = \
+appman_PRE = \
xpsimplehelloworld.man
-EXTRA_DIST = xpsimplehelloworld.sgml
+EXTRA_DIST = \
+ xpsimplehelloworld.sgml
+
+appmandir = $(APP_MAN_DIR)
+
+appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
+
+EXTRA_DIST += $(appman_PRE)
+CLEANFILES = $(appman_DATA)
+
+SED = sed
+
+# Strings to replace in man pages
+XORGRELSTRING = @PACKAGE_STRING@
+ XORGMANNAME = X Version 11
+
+MAN_SUBSTS = \
+ -e 's|__vendorversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
+ -e 's|__xorgversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
+ -e 's|__xservername__|Xorg|g' \
+ -e 's|__xconfigfile__|xorg.conf|g' \
+ -e 's|__projectroot__|$(prefix)|g' \
+ -e 's|__apploaddir__|$(appdefaultdir)|' \
+ -e 's|__appmansuffix__|$(APP_MAN_SUFFIX)|g' \
+ -e 's|__libmansuffix__|$(LIB_MAN_SUFFIX)|g' \
+ -e 's|__adminmansuffix__|$(ADMIN_MAN_SUFFIX)|g' \
+ -e 's|__miscmansuffix__|$(MISC_MAN_SUFFIX)|g' \
+ -e 's|__filemansuffix__|$(FILE_MAN_SUFFIX)|g'
+
+SUFFIXES = .$(APP_MAN_SUFFIX) .man
+
+.man.$(APP_MAN_SUFFIX):
+ sed $(MAN_SUBSTS) < $< > $@