summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:25 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:25 -0500
commitb2195bb0c4369f00316fdd1e21ef7e2541165cfe (patch)
treeb1d92c9f945f1f4356ef335b7c5fd698653416df /Makefile.am
parenta3c0354a29b71e176df879c95bbc879b63c06649 (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9f7d128..103ae0b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,3 +26,13 @@ MOTIFAPPS=
endif
SUBDIRS = $(MOTIFAPPS) xphelloworld xpsimplehelloworld xpxthelloworld
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog