summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 3 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 4ab1100..1f5011d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,10 +8,6 @@ AC_CONFIG_SRCDIR([src/main.c])
AM_INIT_AUTOMAKE()
AM_CONFIG_HEADER(config.h)
-AC_ARG_ENABLE(expat,
- [ --enable-expat Enable expat XML parser support],
- enable_expat=$enableval, enable_expat=no )
-
AC_ARG_WITH(expat-includes,
[ --with-expat-includes=DIR Use Expat includes in DIR],
expat_includes=$withval, expat_includes=yes)
@@ -78,20 +74,11 @@ esac
case "$expat_lib" in
yes)
-
- case "$expat" in
- yes|"")
- EXPAT_LIBS="-lexpat"
- ;;
- *)
- EXPAT_LIBS="-L$expat/lib -lexpat"
- ;;
- esac
-
+ EXPAT_LIBS="-lexpat"
;;
-no)
+ no)
;;
-*)
+ *)
EXPAT_LIBS="-L$expat_lib -lexpat"
;;
esac