summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-05 22:51:11 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-05 22:51:11 +0000
commitfb0ffe45044025c82e1597b9cff7f8e1b2f216e6 (patch)
treee75a483a70cfb97f2a0914d3dcd0f551470765a6 /Makefile.am
parentfeaa900afe02312131f4f6f503fe6efa85a41eba (diff)
Add build systems for xlogo, xlsatoms, xlsclients, xmag, xman, xmessage,
xmh, xmore. lib/Xaw/xaw.m4: Add an AM_CONDITIONAL and a shell variable xaw_use_xprint symlink.sh: add some extra files for xgc, xinit, xkbcomp, xlogo, xmb, and xmodmap xc/programs/xmore/xmore.c: Conditionalize use of xprint
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am78
1 files changed, 78 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..0311082
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,78 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+bin_PROGRAMS = xman
+
+xman_CFLAGS = $(DEP_CFLAGS)
+xman_LDADD = $(DEP_LIBS)
+
+xman_SOURCES = \
+ buttons.c \
+ defs.h \
+ globals.c \
+ globals.h \
+ handler.c \
+ help.c \
+ iconclosed.h \
+ icon_help.h \
+ icon_open.h \
+ main.c \
+ man.c \
+ man.h \
+ misc.c \
+ ScrollByL.c \
+ ScrollByL.h \
+ ScrollByLP.h \
+ search.c \
+ tkfuncs.c \
+ vendor.c \
+ vendor.h \
+ version.h
+
+if XAW_USE_XPRINT
+xman_SOURCES += \
+ print.c \
+ print.h
+endif
+
+dist_man_MANS = \
+ xman.man
+
+# App default files (*.ad)
+
+appdefaultdir = $(sysconfdir)/X11/app-defaults
+
+
+APPDEFAULTFILES = \
+ Xman \
+ Xman-noxprint \
+ Xman-xprint
+
+
+$(APPDEFAULTFILES): %: %.ad
+ cp $< $@
+
+appdefault_DATA = $(APPDEFAULTFILES)
+
+EXTRA_DIST = $(foreach FILE, $(APPDEFAULTFILES), $(FILE).ad)
+
+CLEANFILES = $(APPDEFAULTFILES)
+