summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-05 22:51:11 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-05 22:51:11 +0000
commit38ca5441b199b16b3d2dee2c2b8eaa133aec99a9 (patch)
treec29f1fbb9ab1da549307f513be96b167185d3075 /Makefile.am
parent0cac7e38453d2c9c670fb9f9100c244bf9f7b98e (diff)
Add build systems for xlogo, xlsatoms, xlsclients, xmag, xman, xmessage,
xmh, xmore. lib/Xaw/xaw.m4: Add an AM_CONDITIONAL and a shell variable xaw_use_xprint symlink.sh: add some extra files for xgc, xinit, xkbcomp, xlogo, xmb, and xmodmap xc/programs/xmore/xmore.c: Conditionalize use of xprint
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am58
1 files changed, 58 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..cd245f4
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,58 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+bin_PROGRAMS = xmag
+
+xmag_CFLAGS = $(DEP_CFLAGS)
+xmag_LDADD = $(DEP_LIBS) -lm
+
+xmag_SOURCES = \
+ CutPaste.c \
+ CutPaste.h \
+ RootWin.c \
+ RootWin.h \
+ RootWinP.h \
+ Scale.c \
+ Scale.h \
+ ScaleP.h \
+ xmag.c
+
+dist_man_MANS = \
+ xmag.man
+
+# App default files (*.ad)
+
+appdefaultdir = $(sysconfdir)/X11/app-defaults
+
+
+APPDEFAULTFILES = \
+ Xmag
+
+
+$(APPDEFAULTFILES): %: %.ad
+ cp $< $@
+
+appdefault_DATA = $(APPDEFAULTFILES)
+
+EXTRA_DIST = $(foreach FILE, $(APPDEFAULTFILES), $(FILE).ad)
+
+CLEANFILES = $(APPDEFAULTFILES)
+