summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-05 22:51:10 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-05 22:51:10 +0000
commit0dd5d7bf6f87df04b4d83ba5cc9356c6eed71088 (patch)
tree0846ff9f0fbd2126b4020c1ac76a4f2b9e83704f /configure.ac
parent0e0e651357c2fd8787a3b7007120e0776f2063af (diff)
Add build systems for xlogo, xlsatoms, xlsclients, xmag, xman, xmessage,
xmh, xmore. lib/Xaw/xaw.m4: Add an AM_CONDITIONAL and a shell variable xaw_use_xprint symlink.sh: add some extra files for xgc, xinit, xkbcomp, xlogo, xmb, and xmodmap xc/programs/xmore/xmore.c: Conditionalize use of xprint
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 39 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..4bbe351
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,39 @@
+
+dnl Copyright 2005 Red Hat, Inc.
+dnl
+dnl Permission to use, copy, modify, distribute, and sell this software and its
+dnl documentation for any purpose is hereby granted without fee, provided that
+dnl the above copyright notice appear in all copies and that both that
+dnl copyright notice and this permission notice appear in supporting
+dnl documentation, and that the name of Red Hat not be used in
+dnl advertising or publicity pertaining to distribution of the software without
+dnl specific, written prior permission. Red Hat makes no
+dnl representations about the suitability of this software for any purpose. It
+dnl is provided "as is" without express or implied warranty.
+dnl
+dnl RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+dnl EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+dnl PERFORMANCE OF THIS SOFTWARE.
+dnl
+dnl Process this file with autoconf to create configure.
+
+AC_PREREQ([2.57])
+AC_INIT(xlsatoms,[7.0], [xorg@freedesktop.org],xlsatoms)
+AM_INIT_AUTOMAKE([dist-bzip2])
+AM_MAINTAINER_MODE
+
+AM_CONFIG_HEADER(config.h)
+
+AC_PROG_CC
+AC_PROG_INSTALL
+
+# Checks for pkg-config packages
+PKG_CHECK_MODULES(DEP, x11 xmu)
+AC_SUBST(DEP_CFLAGS)
+AC_SUBST(DEP_LIBS)
+
+AC_OUTPUT([Makefile])