summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-10-14 00:25:46 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-10-14 00:25:46 +0000
commitec56e606da86b5fba8b5bd8a4ab05ca8bd126da7 (patch)
treec2711caabe82a4b566c4038ef9a9ef572e0ffaac /Makefile.am
parentf486eb03eb2281709466d8dc978b19ebe7ab7815 (diff)
Use sed to fill in variables in man page
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am33
1 files changed, 32 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 69196fd..66cab57 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,6 +27,37 @@ xlsatoms_LDADD = $(XLSATOMS_LIBS)
xlsatoms_SOURCES = \
xlsatoms.c
-dist_man1_MANS = \
+appman_SOURCES = \
xlsatoms.man
+
+appmandir = $(mandir)/man$(APP_MAN_SUFFIX)
+
+appman_DATA = $(appman_SOURCES:man=$(APP_MAN_SUFFIX))
+
+EXTRA_DIST = $(appman_SOURCES)
+CLEANFILES = $(appman_DATA)
+
+SED = sed
+
+# Strings to replace in man pages
+XORGRELSTRING = @PACKAGE_STRING@
+ XORGMANNAME = X Version 11
+
+MAN_SUBSTS = \
+ -e 's|__vendorversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
+ -e 's|__xorgversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
+ -e 's|__xservername__|Xorg|g' \
+ -e 's|__xconfigfile__|xorg.conf|g' \
+ -e 's|__projectroot__|$(prefix)|g' \
+ -e 's|__apploaddir__|$(appdefaultdir)|' \
+ -e 's|__appmansuffix__|$(APP_MAN_SUFFIX)|g' \
+ -e 's|__libmansuffix__|$(LIB_MAN_SUFFIX)|g' \
+ -e 's|__adminmansuffix__|$(ADMIN_MAN_SUFFIX)|g' \
+ -e 's|__miscmansuffix__|$(MISC_MAN_SUFFIX)|g' \
+ -e 's|__filemansuffix__|$(FILE_MAN_SUFFIX)|g'
+
+SUFFIXES = .$(APP_MAN_SUFFIX) .man
+
+.man.$(APP_MAN_SUFFIX):
+ sed $(MAN_SUBSTS) < $< > $@