summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-05 22:51:10 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-05 22:51:10 +0000
commit0dd5d7bf6f87df04b4d83ba5cc9356c6eed71088 (patch)
tree0846ff9f0fbd2126b4020c1ac76a4f2b9e83704f /Makefile.am
parent0e0e651357c2fd8787a3b7007120e0776f2063af (diff)
Add build systems for xlogo, xlsatoms, xlsclients, xmag, xman, xmessage,
xmh, xmore. lib/Xaw/xaw.m4: Add an AM_CONDITIONAL and a shell variable xaw_use_xprint symlink.sh: add some extra files for xgc, xinit, xkbcomp, xlogo, xmb, and xmodmap xc/programs/xmore/xmore.c: Conditionalize use of xprint
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..0341637
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,32 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+bin_PROGRAMS = xlsatoms
+
+xlsatoms_CFLAGS = $(DEP_CFLAGS)
+xlsatoms_LDADD = $(DEP_LIBS)
+
+xlsatoms_SOURCES = \
+ xlsatoms.c
+
+dist_man_MANS = \
+ xlsatoms.man
+