summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-07-12 10:53:34 +0100
committerDaniel Stone <daniel@fooishbar.org>2010-07-12 10:53:34 +0100
commit988eb0e121c0f2c992031002acb7274c2026764b (patch)
tree43eb2e806f32a02158492a42ab2b4b65f59e0d34 /configure.ac
parent446d226f85433aeb45834b65f966397ad6fbb17f (diff)
config: allow to build tarball when yacc is missing
Autoconf does not handle this scenario as well as Automake does. If xkbparse.c is already there, do not abort the configuration if yacc is missing as it is not needed. If both xkbparse.c and yacc are missing, abort configuration. Yacc is a required tool to build the package. Reported-by: Julien Cristau <jcristau@debian.org> Signed-off-by: Gaetan Nadon <memsize@videotron.ca> Signed-off-by: Daniel Stone <daniel@fooishbar.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3ad342c..dbda296 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,7 +36,8 @@ AM_CONFIG_HEADER(config.h)
AC_PROG_CC
AC_PROG_YACC
AC_PATH_PROG([YACC_INST], $YACC)
-test -z "$YACC_INST" && AC_MSG_ERROR([yacc not found - unable to compile xkbparse.y])
+AC_CHECK_FILE([$srcdir/xkbparse.c], [],
+ [test -z "$YACC_INST" && AC_MSG_ERROR([yacc not found - unable to compile xkbparse.y])])
AC_PROG_INSTALL