summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2009-03-07 16:36:51 -0800
committerDan Nicholson <dbn.lists@gmail.com>2009-03-07 16:36:51 -0800
commit2fd42dae8840089727f95211abdb86316e566afd (patch)
tree18d3d9f9b55a768ff5ebb7f109f61d99d47b04ae /configure.ac
parent3b816fe819bd849acdbabcfba769041bd3eab753 (diff)
Allow the default XKB config root to be set from configure
The default was hardcoded in the Makefile as $(datadir)/share/X11/xkb. This could cause a problem if you are installing xkbcomp to an alternate location but want to continue using the system's XKB data. Signed-off-by: Dan Nicholson <dbn.lists@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0470334..9543655 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,6 +45,13 @@ XKBCOMP_CFLAGS="$CWARNFLAGS $XKBCOMP_CFLAGS"
AC_SUBST(XKBCOMP_CFLAGS)
AC_SUBST(XKBCOMP_LIBS)
+AC_ARG_WITH([xkb_config_root],
+ [AC_HELP_STRING([--with-xkb-config-root=<paths>],
+ [Set default XKB config root (default: ${datadir}/X11/xkb)])],
+ [XKBCONFIGROOT="$withval"],
+ [XKBCONFIGROOT='${datadir}/X11/xkb'])
+AC_SUBST([XKBCONFIGROOT])
+
XORG_MANPAGE_SECTIONS
XORG_RELEASE_VERSION
XORG_CHANGELOG