summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-10-03 14:51:44 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-10-03 14:51:44 -0700
commit3a59c294d30f5c68dc1411a1a7a274948e08d528 (patch)
tree359fe082a5e2d162559b51a2e702a74da9acc169 /configure.ac
parent98c7700d5bff9e61a7f29d8a611edc8a34961e8e (diff)
Migrate to xorg macros 1.3 & XORG_DEFAULT_OPTIONS
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 4 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 7f354f9..29b6961 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,9 +25,9 @@ AC_INIT(xinit,[1.1.1], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg]
AM_INIT_AUTOMAKE([dist-bzip2])
AM_MAINTAINER_MODE
-# Require xorg-macros: XORG_CWARNFLAGS, XORG_CHANGELOG
-m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.2)
+# Require xorg-macros: XORG_DEFAULT_OPTIONS
+m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
AM_CONFIG_HEADER(config.h)
@@ -45,7 +45,7 @@ AC_CHECK_FUNCS([killpg])
m4_ifdef([AS_HELP_STRING], , [m4_define([AS_HELP_STRING], m4_defn([AC_HELP_STRING]))])
-XORG_CWARNFLAGS
+XORG_DEFAULT_OPTIONS
# Build options
DEFAULT_XRDB=xrdb
@@ -143,7 +143,6 @@ case $host_os in
;;
esac
-XINIT_CFLAGS="$CWARNFLAGS $XINIT_CFLAGS"
AC_SUBST(XINIT_CFLAGS)
AC_SUBST(XINIT_LIBS)
@@ -195,9 +194,5 @@ AC_SUBST(XINIT)
# Cheat, lie, and assume all the world is Xorg for now
AC_DEFINE(XORG, 1, [Define if you have Xorg X server])
-XORG_MANPAGE_SECTIONS
-XORG_RELEASE_VERSION
-XORG_CHANGELOG
-
AC_OUTPUT([Makefile])
AC_OUTPUT([privileged_startx/Makefile])