summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2022-11-07 16:03:47 -0800
committerAlan Coopersmith <alan.coopersmith@oracle.com>2022-11-07 16:03:47 -0800
commit167ad7fa3a339da96798da49d05c3125045a87c2 (patch)
treecef81cd9a3fc39878ec8a4c874ffe71905877d0a /Makefile.am
parent4b54c211e5e86d6ed62386ad9b7d676808b55766 (diff)
Use gettext() to localize messages if available
Originally fixed for Solaris in May 2000 by Steve Swales under Sun bug 4256527 "xhost messages not internationalized" Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4c67a4f..07f36b2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,3 +19,14 @@ ChangeLog:
dist-hook: ChangeLog INSTALL
EXTRA_DIST = README.md
+
+if USE_GETTEXT
+AM_CPPFLAGS = -DLOCALEDIR='"$(LOCALEDIR)"'
+
+noinst_DATA = xhost.po
+
+xhost.po: $(xhost_SOURCES:%=$(srcdir)/%)
+ $(AM_V_GEN)xgettext -d xhost -n $(xhost_SOURCES:%=$(srcdir)/%)
+
+CLEANFILES = xhost.po
+endif