summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 949aeba..d1035d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,7 +36,8 @@ XORG_DEFAULT_OPTIONS
AC_PROG_LEX
AC_PROG_YACC
AC_PATH_PROG([YACC_INST], $YACC)
-test -z "$YACC_INST" && AC_MSG_ERROR([yacc not found - unable to compile gram.y])
+AC_CHECK_FILE([$srcdir/gram.c], [],
+ [test -z "$YACC_INST" && AC_MSG_ERROR([yacc not found - unable to compile gram.y])])
AC_PROG_CC
AC_PROG_INSTALL