summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-06-17 18:56:09 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-06-17 18:56:09 -0700
commitbe599b68334d2dea71e12f478e3201d3087ddf56 (patch)
treece6780642248ed5d66235267f980ca4f667729ca /configure.ac
parent93f75eed7b7dd1208d6d24ec065dfd1518efa599 (diff)
Add --disable-devel-docs flag to configure to skip xfs-design doc conversion
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3fc92cf..301a214 100644
--- a/configure.ac
+++ b/configure.ac
@@ -90,6 +90,13 @@ AC_ARG_WITH(default-font-path, AS_HELP_STRING([--with-default-font-path=PATH], [
[ FONTPATH="${DEFAULT_FONT_PATH}" ])
AC_SUBST([FONTPATH])
+# Option to enable support for building developer internals docs
+AC_ARG_ENABLE(devel-docs,
+ AS_HELP_STRING([--enable-devel-docs],
+ [Build internals documentation for developers (default: enabled)]),
+ [DEVEL_DOCS=$enableval], [DEVEL_DOCS=yes])
+AM_CONDITIONAL([MAKE_DEVEL_DOCS], [test "x$DEVEL_DOCS" = "xyes"])
+
# Option to enable support for starting from inetd
AC_ARG_ENABLE(inetd,
AS_HELP_STRING([--enable-inetd],