summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-08-04 16:10:26 -0400
committerGaetan Nadon <memsize@videotron.ca>2010-08-06 20:50:36 -0400
commitec0bcb3daf87368ff22be65f66c70dbb7ab48d32 (patch)
tree4a6e43e969436b129a60790a26263784a6d32cf5 /Makefile.am
parent884dc954c93e49a31047b84dcf01e0c3e40e08f6 (diff)
xfs.man: use sed and standard makefile
Remove the complexity of using the C preprocessor legacy from IMakefile. Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com> Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 2 insertions, 18 deletions
diff --git a/Makefile.am b/Makefile.am
index 980f185..c54396b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,7 +19,7 @@
# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
# PERFORMANCE OF THIS SOFTWARE.
-SUBDIRS=doc
+SUBDIRS=doc man
configdir = $(sysconfdir)/X11/fs
@@ -94,9 +94,6 @@ xfs_SOURCES = \
include/swaprep.h \
include/swapreq.h
-appman_PRE = \
- xfs.man
-
FSERRORS = /var/log/xfs.log
# Strings to replace in config.cpp
@@ -109,15 +106,6 @@ EXTRA_DIST = xfs.def config.cpp
MAINTAINERCLEANFILES = ChangeLog INSTALL
CLEANFILES = config
-appmandir = $(APP_MAN_DIR)
-
-appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
-
-EXTRA_DIST += $(appman_PRE)
-CLEANFILES += $(appman_DATA)
-
-SED = sed
-
# Translate XCOMM into pound sign with sed, rather than passing -DXCOMM=XCOMM
# to cpp, because that trick does not work on all ANSI C preprocessors.
# Delete line numbers from the cpp output (-P is not portable, I guess).
@@ -147,15 +135,11 @@ MANDEFS = \
-D__configfiledesc__="$(CONFIG_FILE_DESC)" \
-D__configfilepath__="$(CONFIG_FILE_PATH)"
-SUFFIXES = .$(APP_MAN_SUFFIX) .man .cpp
+SUFFIXES = .cpp
.cpp:
$(AM_V_GEN)$(RAWCPP) $(RAWCPPFLAGS) $(CPP_FILES_FLAGS) < $< | $(CPP_SED_MAGIC) > $@
-.man.$(APP_MAN_SUFFIX):
- $(AM_V_GEN)$(RAWCPP) $(RAWCPPFLAGS) $(MANDEFS) $(EXTRAMANDEFS) < $< | $(CPP_SED_MAGIC) > $@
-
-
.PHONY: ChangeLog INSTALL
INSTALL: