summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2011-12-07 13:35:45 -0500
committerGaetan Nadon <memsize@videotron.ca>2011-12-10 13:22:25 -0500
commit677df8dfd37f1018b38b4c8653bde35766d895bc (patch)
tree39f4ef81522ebff0639793e93507a9e1a8490a11 /configure.ac
parent74d5bc691b3a6dcc2dee99ed8b3c15d781b93843 (diff)
Use the Automake recommended alternative to AX_DEFINE_DIR
DATADIR, like any installation variable, is not known at configure time. This is by design to allow setting the variable at make time. The AX_DEFINE_DIR macro worked around this design and consequently cancelled an Automake feature. The alternative method suggested by Automake ends up being simpler while providing the same result as AX_DEFINE_DIR but without cancelling any feature. It is used in the xserver for the parser and in xquartz. The AX_DEFINE_DIR macro has been removed from the Autoconf Archive. There are no official providers for this macro anymore. Separate pre-processor from compiler flags. XFD_CFLAGS and CWARNFLAGS may contain compiler flags. Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com> Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 51fadfb..f4e84e0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,7 +24,6 @@ dnl Process this file with autoconf to create configure.
AC_PREREQ([2.60])
AC_INIT([xfd],[1.1.0],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [xfd])
-AC_CONFIG_MACRO_DIR([m4])
AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
@@ -43,7 +42,7 @@ AC_MSG_CHECKING([where to install localized messages])
AC_ARG_WITH([localedir], AS_HELP_STRING([--with-localedir=<path>],
[Path to install message files in (default: datadir/locale)]),
[LOCALEDIR=${withval}], [LOCALEDIR=${datadir}/locale])
-AX_DEFINE_DIR([LOCALEDIR], [LOCALEDIR], [Location of translated messages])
+AC_SUBST([LOCALEDIR])
if test "x$LOCALEDIR" = "xno" -o "x$USE_GETTEXT" = "xno" ; then
AC_MSG_RESULT([nowhere])
USE_GETTEXT="no"