summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2024-04-21 14:17:08 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2024-04-27 11:25:15 -0700
commit998281c7a865da06d9c6fb832484a20d9f9e5e21 (patch)
tree433c8663b442d481dcb1bbc8d274c638b5d6c474 /configure.ac
parent4755b7bacdb77cd0bb47e8be83372e4dfa135bfe (diff)
Present: add -ext present that prints version & screen capabilities
Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com> Part-of: <https://gitlab.freedesktop.org/xorg/app/xdpyinfo/-/merge_requests/13>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b09d1d8..c3d3543 100644
--- a/configure.ac
+++ b/configure.ac
@@ -138,6 +138,12 @@ PKG_CHECK_MODULES(DPY_XTST, xtst,
AC_CHECK_HEADERS([X11/extensions/record.h],,,[#include <X11/Xlib.h>])
CPPFLAGS="$SAVE_CPPFLAGS"],[echo "not found"])
+PKG_CHECK_MODULES(DPY_XPRESENT, xpresent,
+ [SAVE_CPPFLAGS="$CPPFLAGS"
+ CPPFLAGS="$CPPFLAGS $DPY_XPRESENT_CFLAGS $DPY_X11_CFLAGS"
+ AC_CHECK_HEADERS([X11/extensions/Xpresent.h],,,[#include <X11/Xlib.h>])
+ CPPFLAGS="$SAVE_CPPFLAGS"],[echo "not found"])
+
dnl Allow checking code with lint, sparse, etc.
XORG_WITH_LINT