summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-08-28 19:43:03 -0400
committerGaetan Nadon <memsize@videotron.ca>2010-08-31 20:16:09 -0400
commit674f08cbcbf9c4a29560e8b32e0335d9638b6868 (patch)
tree115af7083b201748cad4061bf2f12c6cee91917c /Makefile.am
parentb8ca599af4a22c5cd1b2aaff203607fe8e5b99d4 (diff)
config: remove copying Chooser.ad to Chooser
This was removed from all other apps with resources in app-defaults. The Chooser resource file is a file in git that gets installed and distributed. Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com> Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 3 insertions, 16 deletions
diff --git a/Makefile.am b/Makefile.am
index b226282..341e65a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -155,25 +155,12 @@ chooser_LDADD = $(CHOOSER_LIBS)
chooser_SOURCES = \
chooser.c
-# App default files (*.ad)
+# App default files
+# This ensures distcheck is performed in a location where user has write access
DISTCHECK_CONFIGURE_FLAGS = --with-appdefaultdir=\$${datadir}/X11/app-defaults
-appdefaultdir = @appdefaultdir@
-
-APPDEFAULTFILES = app-defaults/Chooser
-
-SUFFIXES += .ad
-
-.ad:
- [ -d app-defaults ] || mkdir app-defaults
- cp $< $@
-
-appdefault_DATA = $(APPDEFAULTFILES)
-
-CLEANFILES += $(APPDEFAULTFILES)
-
-EXTRA_DIST += $(APPDEFAULTFILES:%=%.ad)
+dist_appdefault_DATA = app-defaults/Chooser
if LINT
ALL_LINT_FLAGS=$(LINT_FLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \