summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-06 19:53:30 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-06 19:53:30 +0000
commita72338b2f0fef721d6388d292ece4b21f19e9def (patch)
tree31f8d3b7dc69fba9fd1b96f13ec0f151aafdd63d /Makefile.am
parentf6f89b92dce48d65da1e89debbf15b1ff8b727de (diff)
Build system for xditview
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am62
1 files changed, 62 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..92316dc
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,62 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+bin_PROGRAMS = xditview
+
+xditview_CFLAGS = $(DEP_CFLAGS)
+xditview_LDADD = $(DEP_LIBS) -lm
+
+xditview_SOURCES = \
+ draw.c \
+ Dvi.c \
+ DviChar.c \
+ DviChar.h \
+ Dvi.h \
+ DviP.h \
+ font.c \
+ lex.c \
+ Menu.h \
+ page.c \
+ parse.c \
+ xditview.c \
+ XFontName.c \
+ XFontName.h
+
+dist_man_MANS = \
+ xditview.man
+
+# App default files (*.ad)
+
+appdefaultdir = $(sysconfdir)/X11/app-defaults
+
+APPDEFAULTFILES = \
+ Xditview \
+ Xditview-chrtr
+
+$(APPDEFAULTFILES): %: %.ad
+ cp $< $@
+
+appdefault_DATA = $(APPDEFAULTFILES)
+
+EXTRA_DIST = $(foreach FILE, $(APPDEFAULTFILES), $(FILE).ad) xdit.bm xdit_mask.bm
+
+CLEANFILES = $(APPDEFAULTFILES)
+