summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2014-10-20 17:57:04 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2014-10-20 18:00:52 -0700
commit14bfab3bb34f5ab75f2ac6c4acb3b67201e89a69 (patch)
tree55919167f7c1c44e11887c6f4e9407ca922b7997 /Makefile.am
parent6c1110fbe18dcf91228449c3a4ce706edbfb90c7 (diff)
config: move man pages into their own directory
Use services provided by XORG_MANPAGE_SECTIONS. Use standard Makefile for man pages. Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 7 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 38a0c9f..25d5adb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,20 +1,19 @@
+SUBDIRS = man
+
bin_PROGRAMS = xcompmgr
-man_MANS = xcompmgr.1
AM_CFLAGS = $(CWARNFLAGS) $(XCOMPMGR_CFLAGS)
xcompmgr_LDADD = $(XCOMPMGR_LIBS) -lm
-EXTRA_DIST = \
- autogen.sh \
- ChangeLog \
- ${man_MANS}
+MAINTAINERCLEANFILES = ChangeLog INSTALL
-MAINTAINERCLEANFILES=ChangeLog
+.PHONY: ChangeLog INSTALL
-.PHONY: ChangeLog
+INSTALL:
+ $(INSTALL_CMD)
ChangeLog:
$(CHANGELOG_CMD)
-dist-hook: ChangeLog
+dist-hook: ChangeLog INSTALL