summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 1 insertions, 20 deletions
diff --git a/Makefile.am b/Makefile.am
index c8a12ae..58273bc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,6 +19,7 @@
# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
# PERFORMANCE OF THIS SOFTWARE.
+SUBDIRS = man
bin_PROGRAMS = xclipboard xcutsel
AM_CFLAGS = $(CWARNFLAGS) $(XCLIPBOARD_CFLAGS)
@@ -37,12 +38,6 @@ xcutsel_LDADD = $(XCLIPBOARD_LIBS)
xcutsel_SOURCES = \
xcutsel.c
-# man pages
-
-appman_PRE = \
- xclipboard.man \
- xcutsel.man
-
# App default files (*.ad)
DISTCHECK_CONFIGURE_FLAGS = --with-appdefaultdir=\$${datadir}/X11/app-defaults
@@ -52,21 +47,7 @@ appdefaultdir = @appdefaultdir@
dist_appdefault_DATA = \
app-defaults/XClipboard
-
-appmandir = $(APP_MAN_DIR)
-
-appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
-
-EXTRA_DIST = $(appman_PRE)
MAINTAINERCLEANFILES = ChangeLog INSTALL
-CLEANFILES = $(appman_DATA)
-
-SUFFIXES = .$(APP_MAN_SUFFIX) .man
-
-# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
-.man.$(APP_MAN_SUFFIX):
- $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@
-
.PHONY: ChangeLog INSTALL