summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2006-11-07 18:46:11 -0800
committerAlan Coopersmith <alan.coopersmith@sun.com>2006-11-07 18:46:11 -0800
commitc472f5f9257e6dcb9e82042a99ef028e3390e93e (patch)
tree6a1171b228aca88688df05df8577788c8781ec5c /Makefile.am
parentaa27f60ff70230990bd7351bbfda3d38f95afe3b (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 45a089d..f10cb95 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,7 +32,7 @@ appmandir = $(APP_MAN_DIR)
appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
-EXTRA_DIST = $(appman_PRE) filenames.sed.c
+EXTRA_DIST = $(appman_PRE) filenames.sed.c ChangeLog
CLEANFILES = $(appman_DATA) filenames.sed
SED = sed
@@ -71,3 +71,10 @@ ALL_LINT_FLAGS=$(LINT_FLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
lint:
$(LINT) $(ALL_LINT_FLAGS) $(sessreg_SOURCES)
endif LINT
+
+MAINTAINERCLEANFILES=ChangeLog
+
+ChangeLog:
+ git-log > ChangeLog
+
+dist-hook: ChangeLog