summaryrefslogtreecommitdiff
path: root/contexts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contexts/Makefile.am')
-rw-r--r--contexts/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/contexts/Makefile.am b/contexts/Makefile.am
index f96dc15..6e3824a 100644
--- a/contexts/Makefile.am
+++ b/contexts/Makefile.am
@@ -19,3 +19,10 @@ x11r6: x11r6.in
$(AM_V_GEN)$(SED) $(PATH_SUBSTS) < $< > $@
CLEANFILES = $(contexts_DATA)
+
+install-data-hook:
+ $(AM_V_GEN)(cd $(DESTDIR)$(contextsdir) && rm -f x && $(LN_S) x11r6 x)
+ $(AM_V_GEN)(cd $(DESTDIR)$(contextsdir) && rm -f x11 && $(LN_S) x11r6 x11)
+
+uninstall-hook:
+ $(AM_V_at)(cd $(DESTDIR)$(contextsdir) && rm -f x x11)