summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-16 20:35:29 -0200
committerPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-16 20:35:29 -0200
commitb45d6dc185344c5959204e47ec14a489b8a575d5 (patch)
tree11d3924eb127b31236ef6624529a3dab0b43a896 /configure.ac
parent97a85d8ff807798802badfb3e8c51ebcd42fab6f (diff)
Ansification and compile warning fixes.
This also uses XORG_CHANGELOG and XORG_CWARNFLAGS, corrects make distcheck and most gcc 4.3 and sparse warnings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0cd977c..22067ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,6 +26,10 @@ AC_INIT(proxymngr,[1.0.1], [https://bugs.freedesktop.org/enter_bug.cgi?product=x
AM_INIT_AUTOMAKE([dist-bzip2])
AM_MAINTAINER_MODE
+# Require xorg-macros: XORG_CWARNFLAGS, XORG_CHANGELOG
+m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.2)
+
# The program itself has a header called config.h so
# we have to choose a different name
AM_CONFIG_HEADER(xconfig.h)
@@ -34,6 +38,8 @@ AC_PROG_CPP
AC_PROG_CC
AC_PROG_INSTALL
+XORG_CWARNFLAGS
+
AC_PATH_PROG(LBXPROXY, lbxproxy)
if [[ -z $LBXPROXY ]] ; then
AC_MSG_ERROR([lbxproxy is needed])
@@ -46,17 +52,19 @@ fi
# Checks for pkg-config packages
PKG_CHECK_MODULES(PROXYMNGR, ice xt x11 xproxymngproto)
+PROXYMNGR_CFLAGS="$CWARNFLAGS $PROXYMNGR_CFLAGS"
AC_SUBST(PROXYMNGR_CFLAGS)
AC_SUBST(PROXYMNGR_LIBS)
AC_CHECK_FUNC(strcasecmp, [],
AC_DEFINE([NEED_STRCASECMP],1,
- [Define to 1 if you do not have the `strcasecmp' function.]))
+ [Define to 1 if you do not have the "strcasecmp" function.]))
# Needed to check for IPv6 support and set flags appropriately
XTRANS_TCP_FLAGS
XORG_MANPAGE_SECTIONS
XORG_RELEASE_VERSION
+XORG_CHANGELOG
AC_OUTPUT([Makefile])