summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-10-10 22:26:24 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-10-10 22:26:24 -0700
commit245160adaca3957ead8fc278387c20e11b9bb7d2 (patch)
treead762ae594e700f03e642b455102548b0a9ef2e7 /configure.ac
parent2ff1863a387a393e237e9f05525a48806e900368 (diff)
Migrate to xorg macros 1.3 & XORG_DEFAULT_OPTIONS
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 6 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 7129d87..b72ce78 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,14 +27,16 @@ AM_MAINTAINER_MODE
AM_CONFIG_HEADER(config.h)
-# Require xorg-macros version >= 1.2.0 for XORG_CWARNFLAGS & XORG_CHANGELOG
-m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.2)
+# Require xorg-macros 1.3 or later: XORG_DEFAULT_OPTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
AC_PROG_CC
-XORG_CWARNFLAGS
AC_PROG_INSTALL
+XORG_DEFAULT_OPTIONS
+
AC_CHECK_LIB(z, gzopen, [],
[AC_MSG_ERROR([zlib is required, but was not found.])])
@@ -59,8 +61,4 @@ AC_SUBST(X11_CFLAGS)
dnl Allow checking code with lint, sparse, etc.
XORG_WITH_LINT
-XORG_MANPAGE_SECTIONS
-XORG_RELEASE_VERSION
-XORG_CHANGELOG
-
AC_OUTPUT([Makefile])