summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-04-09 17:41:59 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-04-09 17:41:59 -0700
commit8ce50a587505b6aa03ad6cde8a958b0a0040073d (patch)
tree82f6c4434c36ccc3b2db614de43d5fa7c0a730f5 /configure.ac
parentfbaa81a026aaaf8029487c4e960ef4b8bf58d055 (diff)
Use XORG_CWARNFLAGS instead of hardcoding -Wall in Makefile.am
Also switch changelog generation rule to XORG_CHANGELOG Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d93d690..d992d63 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,8 +8,12 @@ AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([dist-bzip2])
AM_MAINTAINER_MODE
+# Require xorg-macros 1.2 for XORG_CWARNFLAGS, XORG_CHANGELOG
+m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.2)
AC_PROG_CC
+XORG_CWARNFLAGS
AC_PROG_INSTALL
PKG_CHECK_MODULES(XLIB, x11)
@@ -18,8 +22,9 @@ AC_CHECK_HEADERS([stdio.h stdlib.h string.h unistd.h locale.h], , [AC_MSG_FAILUR
AC_CHECK_FUNCS([setlocale], , [AC_MSG_FAILURE("cannot find essential function")])
AC_CHECK_FUNCS([unsetenv])
-
AC_SUBST(XLIB_CFLAGS)
AC_SUBST(XLIB_LIBS)
+XORG_CHANGELOG
+
AC_OUTPUT([Makefile doc/Makefile])